Aller au contenu


iPhone: votre future application doit déjà être compatible avec l’OS 3.0!

Lu ce matin chez Techcrunch (oui, parce que même en tant que développeur iPhone, je n’ai pas -encore?- reçu la fameuse notification de la part d’Apple dont ils parlent): dorénavant, vos soumissions d’applications seront testées sur l’OS 3.0.  Si elles ne sont pas compatibles (nous en sommes actuellement à la Beta 5 du SDK 3.0), votre application sera rejetée.  Bonne idée que de prendre les devants, mais c’est tout de même une sacrée contrainte… Cela veut dire que vous devez disposer d’un iPhone de développement, upgradé en version 3.0.  MAIS, n’upgradez pas votre seul et unique appareil de développement actuellement en 2.x, vous ne pourrez pas revenir en arrière, une fois cette beta installée…  Vous n’aurez alors plus de moyen de tester si votre application fonctionne encore en 2.x!  Ceci dit, votre application doit être compatible avec le 3.0, mais ne peut évidemment utiliser aucune des nouveautés de ce firmware!

Bref, il va falloir mettre la main au portefeuille pour s’assurer que votre application tourne en 2.x, et est toujours compatible avec le futur 3.x (toujours en beta, rappelons-le).  Oui parce que le simulateur est bien, mais ne dispose évidemment pas de fonctionnalités techniques identiques à l’iPhone… De plus,  j’ai également eu plusieurs cas où même son comportement logiciel n’est pas identique à l’iPhone: là où ce dernier ne m’indique aucun memory leak dans mon application, le simulateur – dont la version d’OS est la même – m’en trouve…

Ah, et si vous avez déjà des applications sur le store, prenez également les devants: il faudra qu’elles soient 3.0-ready le jour de la mise à disposition du firmware au grand public.  Sinon: bye bye…

iphones

Photo prise avec le G1… 😉

Posté dans Actu, développement, iPhone. Tags , , .

0 commentaire(s)

Quelques tags HTML sont acceptés

(obligatoire)

(obligatoire, mais ne sera pas diffusé)

ou faire un rétrolien depuis votre site.